Assuming that the outer VRF (including the loopback interfaces) is already made routable (e.g. OSPF, BGP etc) within this network. We are setting up another VRF on the inner for network management purposes.
- On Hub CE Router A:
- interface Tunnel1
- ip vrf forwarding inner
- ip address 192.168.1.1 255.255.255.0
- ip nhrp authentication cisco #ensure matching key for all spokes
- ip nhrp map multicast dynamic
- ip nhrp network-id 123 #also ensure network-id can match
- ip ospf network broadcast
- ip ospf priority 10
- tunnel source Loopback0 #note that the destination is not defined
- tunnel mode gre multipoint
- tunnel key 123 # and the tunnel key as well
- tunnel vrf outer # create a tunnel on the outer vrf
- !
- router ospf 120 vrf inner
- network 172.16.1.1 0.0.0.0 area 0
- network 192.168.1.0 0.0.0.255 area 0
- On spoke router B
- interface Tunnel1
- ip vrf forwarding inner
- ip address 192.168.1.2 255.255.255.0
- ip nhrp authentication cisco
- ip nhrp map 192.168.1.1 10.1.1.1 #map inner vrf to outer vrf on hub router
- ip nhrp map multicast 10.1.1.1 #register with nhrp hub using multicast
- ip nhrp network-id 123
- ip nhrp nhs 192.168.1.1 #define hub router as next hop
- ip ospf network broadcast
- ip ospf priority 0
- tunnel source Loopback0
- tunnel mode gre multipoint
- tunnel key 123
- tunnel vrf outer
- !
- router ospf 120 vrf inner
- network 172.16.1.2 0.0.0.0 area 0
- network 192.168.1.0 0.0.0.255 area 0
- On spoke router C
- interface Tunnel1
- ip vrf forwarding inner
- ip address 192.168.1.3 255.255.255.0
- ip nhrp authentication cisco
- ip nhrp map 192.168.1.1 10.1.1.1 #map inner vrf to outer vrf on hub router
- ip nhrp map multicast 10.1.1.1 #register with nhrp hub using multicast
- ip nhrp network-id 123
- ip nhrp nhs 192.168.1.1 #define hub router as next hop
- ip ospf network broadcast
- ip ospf priority 0
- tunnel source Loopback0
- tunnel mode gre multipoint
- tunnel key 123
- tunnel vrf outer
- !
- router ospf 120 vrf inner
- network 172.16.1.3 0.0.0.0 area 0
- network 192.168.1.0 0.0.0.255 area 0
If you have a second Hub router on the headend, you can setup another multippoint tunnel for redundancy like the following diagram:
Nevertheless, the newly created overlay VPN remains in plain. You may also wish to protect it using IPSec. Cisco calls this combination of IPSec and Multipoint GRE as "Dynamic Multipoint VPN" or "DMVPN", which I should blog about it in my next post.
I really get great volume of information from your post. Thanks for this valuable input.
ReplyDeletePoint to point wifi
Hello,
ReplyDeleteAre the VRF's configured simply as 'vrf inner' with no RD, import and export?
GRE burrow is particularly helpful to exemplify network traffic (counting IGP steering) separate from the basic foundation. One valuable way is to make a legitimate Out-of-Band (OOB) the board interface for network the executives on another VRF. The default highlight point GRE burrows are not difficult to arrangement when you have not many far off locales to interface with. It will turn out to be less adaptable, as the quantity of locales develop.
ReplyDelete